Communauté francophone - Jimdo
Bienvenue sur le nouveau forum de discussion officiel de la communauté francophone des utilisateurs de Jimdo.

Ce forum annule et remplace le précédent forum Jimdo, qui a malheureusement dû être fermé pour raisons techniques.

Vous avez un ou plusieurs sites Jimdo ? Enregistrez vous sur le forum, posez vos questions et prenez part aux discussions !

Vous êtes simple visiteur ? Vous pouvez consulter nos pages, mais vous ne pourrez pas laisser de message.

Problème d'affichage d'un widget Secure Holiday

Voir le sujet précédent Voir le sujet suivant Aller en bas

Problème d'affichage d'un widget Secure Holiday

Message par DansLe1000 le Mar 1 Sep 2015 - 20:54

Bonjour,

J'ai un souci sur un site que je crée pour un camping. Il assure ses réservations via la plateforme Secure Holiday, qui lui fournit un widget pour faire apparaître un module de réservation sur le site.

Voici le mode d'emploi (je vous explique mon souci après) :

Pour l’implémenter, il suffit de faire un copié-collé de ce 1er code et de l’ajouter une seule fois juste avant la fin de la balise <body> et ce, peu importe le nombre de widget présent sur votre page :

<script charset="UTF-8" src="//static.secureholiday.net/static/pip2/widgetprovider-v2.js" type="text/javascript"></script>

Faites ensuite un 2ème copié-collé du code ci-dessous et placez-le à l’emplacement de votre choix. Ce code doit rester entre les balises <body> et </body> de votre site internet. Ce code est différent pour chaque établissement :

<script data-wsh-id="XXXXXXXXXXXXXXXXXX_modifié_par_securité=" ></script>


1er problème : à partir d'un design prédéfini Jimdo, je n'ai pas accès au code html (ou bien je ne sais pas le trouver) et ne peut donc pas coller le 1er code "juste avant la fin de la balise </body>". J'ai donc essayé en collant ce code par la fonction "Modifier le header".

Ensuite, j'ai collé le 2ème code via la fonction Widget là où je souhaite qu'il apparaisse. Là, super ! Pendant 1 heure, mon module de réservation s'est bien affiché sur la page ! Mais au bout d'une heure, plus rien ! Ni sur Chrome, ni sur Explorer ou Firefox, ni sur mobile... bref, j'ai des espaces blancs à la place des modules de résa.

Est-ce que vous pouvez m'aider ???

Un très grand merci d'avance Smile

Cécile

DansLe1000

Messages : 3
Date d'inscription : 28/08/2015

http://www.dansle1000.net

Revenir en haut Aller en bas

Re: Problème d'affichage d'un widget Secure Holiday

Message par FilmsdeLover le Mer 2 Sep 2015 - 6:11

Vous avez la bonne méthode pourtant. Le premier code va dans "Modifier le header" et le second dans un module "Widget/HTML" à l'endroit désiré. Sans avoir le site sur lequel le problème existe, difficile de savoir pourquoi ça ne marche pas. Cela peut venir aussi bien de Secure Holiday que de Jimdo donc il nous faudrait un peu plus de précision, et surtout une page sur laquelle vous avez mis le widget, même s'il n'apparait pas.

_________________
Utilisateur de Jimdo depuis 2009 qui peut être grognon parfois si vous ne cherchez pas dans l'Aide Jimdo avant de poser des questions. Je ne bosse pas pour Jimdo.
A consulter : Tutoriels et guides pour Jimdo.
avatar
FilmsdeLover

Messages : 1109
Date d'inscription : 07/10/2014

http://www.filmsdelover.com

Revenir en haut Aller en bas

Re: Problème d'affichage d'un widget Secure Holiday

Message par DansLe1000 le Mer 2 Sep 2015 - 12:41

Bonjour et merci Filmsdelover pour la réponse !

Voici la page sur laquelle j'ai intégré les widget : http://camping-cheverny.jimdo.com/ Dans la sidebar de gauche, il y a un widget réservation entre les 2 tirets de séparation et un widget avis sous le "scotsch" Avis & commentaires. Il y a également un widget réservation sous le slider photos.

En passant par google tools webmaster, j'ai pu voir que le 1er script à copier juste avant la fin de la balise </body> est bien dans le code, mais effectivement dans le head.

Le souci, c'est qu'apparemment, il faut vraiment que ce script soit dans le body pour que l'affichage fonctionne. Et ça, je ne sais pas comment le faire sur un design Jimdo...

Bref, je suis dans le flou et je cherche des réponses. D'autant que d'autres campings ont créé leur site sur Jimdo et qu'ils ont dû avoir le même souci. En effet, je n'en ai trouvé aucun sur lequel le module de résa apparaît.

Il y a donc peut-être là une innovation intéressante à faire pour Jimdo :-) !

En tout cas, si avec ces éléments supplémentaires, vous trouvez une solution à mon problème, ce serait super top !

Merci d'avance, ne serait-ce que pour le temps que vous aurez passé à y réfléchir :-)

Cécile

DansLe1000

Messages : 3
Date d'inscription : 28/08/2015

http://www.dansle1000.net

Revenir en haut Aller en bas

Re: Problème d'affichage d'un widget Secure Holiday

Message par DansLe1000 le Jeu 3 Sep 2015 - 15:56

SOLUTIONNÉ !

Il suffit tout simplement d'intégrer le premier script non pas dans le HEAD du site mais dans la sidebar via un élément widget. Et oui, ces éléments là s'inscrivent automatiquement entre les balises <body> !

Puis dans un autre élément widget la deuxième partie du script.

Et du coup, voici ce que donne mon site avec le module de résa intégré : http://camping-cheverny.jimdo.com/ (Il va très vite passer en Jimdo pro !!).

Un très grand merci à Matthieu, Jimdo Expert à qui j'ai posé la question et qui m'a donné la solution en 5 mn ! Retrouvez ses bonnes astuces sur www.jimdesign.fr Smile

DansLe1000

Messages : 3
Date d'inscription : 28/08/2015

http://www.dansle1000.net

Revenir en haut Aller en bas

Re: Problème d'affichage d'un widget Secure Holiday

Message par Contenu sponsorisé


Contenu sponsorisé


Revenir en haut Aller en bas

Voir le sujet précédent Voir le sujet suivant Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum